Kali Linux是太高端还是太智障?Kali Linux 安装Parallels Tools 流水记录!

话说几个月前,Kali LInux 还是少有支持苹果M1 的Linux系统,还号称很安全很保护隐私,所以吐槽君在M1的Macbook Air 上用Parallels Desktop虚拟了个,今天有个需求要在Linux上跑测试,想起这货,开机发现,完了,因为木有Parallels Tools,两个系统的复制黏贴都不认,这就尴尬了。

安装Parallels Tools,./install 不是报错就是提示权限不做,搞得吐槽君差点删除这货。

算算时间,重新安装太费时间,还是手打命令搞一下吧。

在PD虚拟机上直接点击安装Parallels Tools,点击 install-gui

嗯,理论上新版kali是不行的。。。

那就命令行输入:

cd /media/cdrom0

./install

到这一步,十有八九会提示你权限不足。。。用sudo都没屁用。

网上给出的解决方案是先卸载光驱,再重新挂载:

先卸载:

umount /media/cdrom0

再挂载:

mount -o exec /media/cdrom0

理论上按以上操作,问题可以得到解决。

实际上按以上操作,还是依旧会告诉你:

mount: /media/cdrom0: WARNING: device write-protected, mounted read-only.

( ;´Д`)

最简单的办法,直接在图形界面上复制出来放到本地磁盘

然后命令行给予该目录权限:

chmod 777 -R .

接下来的操作就恶心人了。

提示你这个不行,那个也不行,少组件啊!

我在mac主机下搜到了解决方案,你总让我复制下载链接到kali linux吧?

不行,木有Parallels Tools,你不能从macOS复制任何内容过来

可我复制是为了安装Parallels Tools!

不行,木有Parallels Tools,你不能从macOS复制任何内容过来

(╯°□°)╯︵ ┻━┻

如此反复后,吐槽君决定,老子手打!

http://http.kali.org/kali/pool/main/l/linux/linux-headers-5.10.0-kali3-arm64_5.10.12-1kali1_arm64.deb

http://http.kali.org/kali/pool/main/l/linux/linux-kbuild-5.10-dbgsym_5.10.12-1kali1_arm64.deb

http://http.kali.org/kali/pool/main/l/linux/linux-kbuild-5.10_5.10.12-1kali1_arm64.deb

http://http.kali.org/kali/pool/main/l/linux/linux-headers-5.10.0-kali3-common_5.10.12-1kali1_all.deb

dpkg -i linux-headers-5.10.0-kali3-arm64_5.10.12-1kali1_arm64.deb

dpkg -i linux-kbuild-5.10-dbgsym_5.10.12-1kali1_arm64.deb

dpkg -i linux-kbuild-5.10_5.10.12-1kali1_arm64.deb

dpkg -i linux-headers-5.10.0-kali3-common_5.10.12-1kali1_all.deb

然后重启

./install

全部next,完事

以上,流水账记录完毕!

给TA买糖
共{{data.count}}人
人已赞赏
技术宅

万事屋推荐免费、开源可商用的字体:霞鹜文楷 / LXGW WenKai 兼仿宋和楷体特点,可读性高~

2021-7-31 23:23:44

技术宅

万事屋推荐Chrome/Edge都可以用的全网页截图插件:gofullpage

2021-8-6 15:04:40

3 条回复 A文章作者 M管理员
  1. HelloWorDomain

    嗯,看过后,为当初没买M1感到庆幸。

    • 吐槽君

      除了这种犄角旮旯的问题,m1真心好用,我用了近一年,再也回不去x86的笔记本了 [s-3]

个人中心
今日签到
有新私信 私信列表
搜索